123

Uwaga! Ta wi­try­na wy­ko­rzy­stu­je pli­ki cook­ies w ce­lu umoż­li­wie­nia dzia­ła­nia nie­któ­rych fun­kcji ser­wi­su (np. zmia­ny ko­lo­ru tła, wy­glą­du in­ter­fej­su, itp.) oraz w ce­lu zli­cza­nia li­czby odwie­dzin. Wię­cej in­for­ma­cji znaj­dziesz w Po­li­ty­ce pry­wat­no­ści. Ak­tual­nie Two­ja przeg­lą­dar­ka ma wy­łą­czo­ną ob­słu­gę pli­ków co­o­kies dla tej wi­try­ny. Ten ko­mu­ni­kat bę­dzie wy­świet­la­ny, do­pó­ki nie za­ak­cep­tu­jesz pli­ków cook­ies dla tej wi­try­ny w swo­jej przeg­lą­dar­ce. Ro­zu­miem, ak­cep­tu­ję pli­ki cook­ies!
:
o
[
]
Z
U

Aktualności

Październik 2017

Informuję, że prace nad wersją dziewiątą Kombi trwają i w zasadzie większość kluczowych problemów została już rozwiązana (np. obsługa drukarek, drukowanie przez sieć, kłopoty z uprawnieniami do plików). Program jest testowany na Win7 i Win10 na wersjach 32- i 64-bitowych i działa bardzo dobrze.

Największym problemem była obsługa plików pomocy (pliki z rozszerzeniem *.hlp), dla których wymagany jest program winHlp32.exe, który został całkowicie usunięty z Windowsa 10.

Oczywiście, dla wytrawnych użytkowników Kombi to nie jest problem, ale nie mogłem tego faktu zignorować, bo i tak musiałem przejrzeć i przekompilowywać wszystkie pliki projektu, więc nie racjonalne byłoby tego problemu nie rozwiązać niejako przy okazji. Napisałem więc swój odpowiednik systemowego win32hlp.exe i w konsekwencji cały system pomocy nie wymagał tworzenia od nowa.

Większych nowości w Kombi 9 (poza tym, że działa na nowych systemach :-)) nie należy się spodziewać. Na 99% będzie interpretowany import plików *.pdf. To będzie działało na pewno dla plików *.pfd generowanych z Kombi. Natomiast dla innych plików – w zasadzie też działa, ale jeśli ktoś wygeneruje pdf-a z jakimiś egzotycznymi opcjami, to może być problem (tu prośba żeby takie pliki w przyszłości przysyłać do mnie, abym mógł je przeanalizować i wprowadzić odpowiednie poprawki do interpretera).

Jest też nowy stół montażowy dla plików *.pdf i *.ps (niezależny od tego w Kombi). To jest nowy moduł interpretera PostScriptu manipulujący stronami w plikach *.ps i *.pdf.


Zrobiłem też przymiarkę do obsługi plików *.png z przeźroczystościami i próby są obiecujące. Mój kompilator (mimo, że dość stary) pozwala jeszcze sięgnąć do nowych (wbudowanych w system) bibliotek graficznych i w zwiazku z tym w kolejnej wersji będę chciał zaimplementować przeźroczystości.

Na razie plan jest taki, żeby do końca roku 2017 wypuścić zmodernizowany i odświeżony program działający na wszystkim – od Win95 do Win10 :-).

Wszystkie osoby zainteresowane proszę o zgłaszanie ewentualnych istotnych uwag do programu. Być może uda się przynajmniej część z nich wprowadzić od razu.


Czerwiec 2014

W czer­wcu 2014 prze­nie­sio­no kompilator oraz ko­dy źród­ło­we pa­kie­tu Kombi pod sy­stem Win­dows 7. Ca­łość pa­kie­tu uda­ło się skom­pi­lo­wać pod no­wym sy­ste­mem.

W związ­ku z po­wyż­szym bę­dzie moż­li­we udo­stęp­nie­nie wer­sji dzie­wią­tej pa­kie­tu – do­sto­so­wa­nej do naj­now­szych wer­sji sy­ste­mów Win­dows.

Prosimy o cierpliwość i odwiedzenie tej strony za jakiś czas.


Grudzień 2008

W gru­dniu 2008 ro­ku udo­stęp­nio­no ostatnią komercyjnę wer­sję pakietu – tj. 8.034.


Sierpień 1996

W sier­pniu 1996 roz­po­czę­ły się pra­ce nad wer­sją pa­kie­tu przy­sto­so­wa­ną do pra­cy pod sy­ste­ma­mi Win­dows.